cizgile β Zero-dependency URL slug engine. RFC 3986/3987 slugs, transliteration for 7 scripts, Unicode slugs, IRI β URI, percent-encoding. Pure TypeScript, works everywhere.
JSON for Modern C++
π A real-time monitoring dashboard for Claude Code & Codex, built with SQLite3, Node.js, Express, React, Vite, TailwindCSS, & WebSockets. It tracks sessions, agent activity, tool usage, and subagent orchestration, providing live analytics, a Kanban status board, status notifications, a cute buddy, & an interactive web UI/MacOS/Windows native app.
βοΈ Send e-mails with Node.JS β easy as cake!
RFCs for changes to Rust
Unofficial Galaxy Buds Manager for Windows, macOS, Linux, and Android
The Network UPS Tools repository. UPS management protocol Informational RFC 9271 published by IETF at https://www.rfc-editor.org/info/rfc9271 Please star NUT on GitHub, this helps with sponsorships!
C/C++ WebRTC network library featuring Data Channels, Media Transport, and WebSockets
β° Type-safe datetimes for Python that get DST right. Rust or pure Python, your choice.
Bandit is a pure Elixir HTTP server for Plug & WebSock applications
nRF Connect SDK main repository
A simple cross platform ACME client (for use with Let's Encrypt et al.)
SSL and TLS protocol test suite and fuzzer
A repository for Open Secure AI Alliance participants to collaborate on RFCs and proposals.
Simple to use, blazing fast and thoroughly tested WebSocket client and server for Node.js
Generate RFC-compliant UUIDs in JavaScript
Let's Encrypt/ACME client and library written in Go
An ACME-based certificate authority, written in Go.
ζ΅θ―ε½εη½η»η NAT η±»εοΌSTUNοΌ
WebSocket client for Python
A ruby implementation of the RFC 7519 OAuth JSON Web Token (JWT) standard.
Itty.bitty is a tool to create links that contain small sites
A datetime library for Rust that encourages you to jump into the pit of success.
We're tracking all our Issues, RFCs and a few other documents in this repository.
High performance DNS over HTTPS client & server
rfc 2616 compliant HTTP static-file server module, with built-in caching.
a robust, scalable, and maintained set of caching packages
ngtcp2 project is an effort to implement IETF QUIC protocol
π§ Easy to use, yet comprehensive library for sending mails with Go
:closed_lock_with_key: A PHP library for generating one time passwords according to RFC 4226 (HOTP) and the RFC 6238 (TOTP)
Decision audit trail + persistent memory for AI trading agents. Outcome-weighted recall, tamper-evident SHA-256 chain with RFC 3161 anchoring, 20 MCP tools.
open-source binary diff, delta/differential compression tools, VCDIFF/RFC 3284 delta compression
π Calendar app for Nextcloud
icalendar parser library for Python
Javascript parser for ics (rfc5545) and vcard (rfc6350) data
iCal-creator for PHP
HTTP/3 library written in C
[READ-ONLY] URI manipulation Library
CBOR codec (RFC 8949, RFC 8742) with CBOR tags, Go struct tag options (toarray, keyasint, omitempty, omitzero), float64/32/16, big.Int, and fuzz tested.
RFC6265 Cookies and CookieJar for Node.js
An HTTP cache system, RFC compliant, compatible with @tyktechnologies, @traefik, @caddyserver, @go-chi, @bnkamalesh, @beego, @devfeel, @labstack, @gofiber, @go-goyave, @go-kratos, @gin-gonic, @roadrunner-server, @zalando, @zeromicro, @nginx and @apache
PowerShell module and ACME client to create certificates from Let's Encrypt (or other ACME CA)
A CoAP (RFC 7252) implementation in C
RFCs for changes to Ember
A miniature version of Boulder, Pebble is a small RFC 8555 ACME test server not suited for a production certificate authority.
A repository for gRFCs
A go implementation of the STUN client (RFC 3489 and RFC 5389)
jtx Board allows you to manage your Journals (like meeting minutes), Notes and Tasks in one Android app. The app is compatible with the iCal standard (RFC5545) and is integrated with DAVx5 to allow the synchronisation of entries through CalDAV.
Fast, lightweight, and RFC 4180 compliant CSV library for Java. Zero dependencies, ~90 KiB. Trusted by Apache NiFi, JUnit, and Neo4j.
TLS 1.3 implementation in C (master supports RFC8446 as well as draft-26, -27, -28)
JUICE is a UDP Interactive Connectivity Establishment library
This is an implementation of RFC 6902 JSON Patch written in Java
The NLnet Labs Name Server Daemon (NSD) is an authoritative, RFC compliant DNS nameserver.
RFCs for the AWS CDK
RFCs and docs related to the F# language design process, see https://github.com/fsharp/fslang-suggestions to submit ideas
OpenPGP (RFC4880) Implementation in IcedCoffeeScript
Specifications for Interledger and related protocols
Bicameral deterministic AI runtime: Zero-hallucination System 1/2 reasoning engine with cryptographic audit trails (RFC 8785, Ed25519) and PoSP consensus arbitration.
RFC 9110 HTTP Range parsing and serving for Go, with limits on range count and multipart amplification.
Android app for browsing, editing and installing Galaxy Fit3 (SM-R390) watch faces β edit the face's own binary on a canvas, validate it, then send it to the watch over Bluetooth.